Firefox ne supporte plus les plugins NPAPI comme Java et Silverlight à partir de la version 52 qui est la dernière mise à jour pour XP et Vista

Cela signifie que tous les plugins de navigateur de type NPAPI, tels que Java et Silverlight, ne sont plus supportés par Firefox.

Les plug-ins NPAPI (Netscape Plugin Application Programming Interface) sont désormais désactivés par tous les navigateurs les plus récents pour des raisons de sécurité, à tel point que Chrome qui bloquait les plug-ins NPAPI déjà en 2015.

Le seul plugin NPAPI encore supporté dans Firefox 52 est le Flash Player, encore trop répandu pour être supprimé définitivement, mais qui sera bientôt définitivement supprimé ou, du moins, très limité.

Dans Firefox 52, en allant dans le menu principal de la section Add-ons, vous pouvez cliquer sur les Plugins et noter qu’il n’y en a que deux qui fonctionnent et sont actifs : un appelé OpenH264 Video Codec et Widevine Content Decryption Module fourni par Google, qui sont des plugins non NPAPI.

Quant aux plugins NPAPI comme Java et Silverlight, la seule façon de continuer à les utiliser est par le biais de la version spéciale de Firefox 52 ESR (Extended Support Release), au moins jusqu’en mars 2018.

Firefox 52 est aussi la dernière version du navigateur pour les ordinateurs avec Windows XP et Windows Vista, qui ne recevra plus de mises à jour de ce navigateur.

Notez que Firefox était le seul navigateur qui était encore en train de se mettre à jour dans ces systèmes d’exploitation anciens et maintenant épuisés, qui à l’avenir n’auront plus de navigateur sécurisé pour surfer sur l’Internet.

Voir aussi :  Réduire la consommation de mémoire de Firefox

Pour ces PC, le téléchargement de Firefox 52 restera actif (devrait) même après la sortie de Firefox 53.